Thymeleaf 提示: Cannot perform conversion to XML from legacy HTML:解析

java哥 阅读:214 2021-03-31 13:46:17 评论:0

SpringBoot 1.5.x 集成Thymeleaf 2.1.x 提示如下错误信息:

[http-nio-9096-exec-1] ERROR org.thymeleaf.TemplateEngine - [THYMELEAF][http-nio-9096-exec-1] Exception processing template "index": Cannot perform conversion to XML from legacy HTML: The nekoHTML library is not in classpath. nekoHTML 1.9.15 or newer is required for processing templates in "LEGACYHTML5" mode [http://nekohtml.sourceforge.net]. Maven spec: "net.sourceforge.nekohtml::nekohtml::1.9.15". IMPORTANT: DO NOT use versions of nekoHTML older than 1.9.15. 
2020-08-04 14:09:28.580 [http-nio-9096-exec-1] ERROR org.apache.catalina.core.ContainerBase.[Tomcat].[localhost].[/].[dispatcherServlet] - Servlet.service() for servlet [dispatcherServlet] in context with path [] threw exception [Request processing failed; nested exception is org.thymeleaf.exceptions.ConfigurationException: Cannot perform conversion to XML from legacy HTML: The nekoHTML library is not in classpath. nekoHTML 1.9.15 or newer is required for processing templates in "LEGACYHTML5" mode [http://nekohtml.sourceforge.net]. Maven spec: "net.sourceforge.nekohtml::nekohtml::1.9.15". IMPORTANT: DO NOT use versions of nekoHTML older than 1.9.15.] with root cause 
org.thymeleaf.exceptions.ConfigurationException: Cannot perform conversion to XML from legacy HTML: The nekoHTML library is not in classpath. nekoHTML 1.9.15 or newer is required for processing templates in "LEGACYHTML5" mode [http://nekohtml.sourceforge.net]. Maven spec: "net.sourceforge.nekohtml::nekohtml::1.9.15". IMPORTANT: DO NOT use versions of nekoHTML older than 1.9.15.

产生改错误的原因是:thymeleaf 设置HTML5版本:

# 设置HTML 模板 
spring.thymeleaf.mode=HTML5

很容易出现以下错误:

org.xml.sax.SAXParseException: 元素类型 "input" 必须由匹配的结束标记 "</input>" 终止。

为了兼容HTML4 和HTML5 ,修改为HTML 的兼容版本:

# 设置HTML兼容版本 
spring.thymeleaf.mode=LEGACYHTML5 

使用HTML兼容版本,提示SpringBoot 1.5.x 集成Thymeleaf 2.1.x 提示如下错误信息:

 

[http-nio-9096-exec-1] ERROR org.thymeleaf.TemplateEngine - [THYMELEAF][http-nio-9096-exec-1] Exception processing template "index": Cannot perform conversion to XML from legacy HTML: The nekoHTML library is not in classpath. nekoHTML 1.9.15 or newer is required for processing templates in "LEGACYHTML5" mode [http://nekohtml.sourceforge.net]. Maven spec: "net.sourceforge.nekohtml::nekohtml::1.9.15". IMPORTANT: DO NOT use versions of nekoHTML older than 1.9.15.

2020-08-04 14:09:28.580 [http-nio-9096-exec-1] ERROR org.apache.catalina.core.ContainerBase.[Tomcat].[localhost].[/].[dispatcherServlet] - Servlet.service() for servlet [dispatcherServlet] in context with path [] threw exception [Request processing failed; nested exception is org.thymeleaf.exceptions.ConfigurationException: Cannot perform conversion to XML from legacy HTML: The nekoHTML library is not in classpath. nekoHTML 1.9.15 or newer is required for processing templates in "LEGACYHTML5" mode [http://nekohtml.sourceforge.net]. Maven spec: "net.sourceforge.nekohtml::nekohtml::1.9.15". IMPORTANT: DO NOT use versions of nekoHTML older than 1.9.15.] with root cause

org.thymeleaf.exceptions.ConfigurationException: Cannot perform conversion to XML from legacy HTML: The nekoHTML library is not in classpath. nekoHTML 1.9.15 or newer is required for processing templates in "LEGACYHTML5" mode [http://nekohtml.sourceforge.net]. Maven spec: "net.sourceforge.nekohtml::nekohtml::1.9.15". IMPORTANT: DO NOT use versions of nekoHTML older than 1.9.15.

产生改错误的原因是:thymeleaf 设置HTML5版本:

 

# 设置HTML 模板

spring.thymeleaf.mode=HTML5

很容易出现以下错误:

 

org.xml.sax.SAXParseException: 元素类型 "input" 必须由匹配的结束标记 "</input>" 终止。

为了兼容HTML4 和HTML5 ,修改为HTML 的兼容版本:

 

# 设置HTML兼容版本

spring.thymeleaf.mode=LEGACYHTML5

使用HTML兼容版本,提示最开始的错误信息,解决方案是添加nekoHTML 1.9.15 或者更新版本,pom.xml 文件如下:

  <dependency> 
			<groupId>net.sourceforge.nekohtml</groupId> 
			<artifactId>nekohtml</artifactId> 
			<version>1.9.22</version> 
		</dependency>

 

声明

1.本站遵循行业规范,任何转载的稿件都会明确标注作者和来源;2.本站的原创文章,请转载时务必注明文章作者和来源,不尊重原创的行为我们将追究责任;3.作者投稿可能会经我们编辑修改或补充。

发表评论
搜索
排行榜
KIKK导航

KIKK导航

关注我们