Attribute "scope" must be declared for element type "bean"解析

无情 阅读:228 2021-03-31 22:23:39 评论:0

在配置Spring实体Bean文件时,提示如下截图错误:


进过一番百度,谷歌之后。出错的原因:原来Attribute "scope"  在spring2.0以后支持。

spring的XML配置文件的这个:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE beans PUBLIC "-//SPRING//DTD BEAN//EN"
    "http://www.springframework.org/dtd/spring-beans.dtd">

改成这个就可以了:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE beans PUBLIC "-//SPRING//DTD BEAN 2.0//EN"
    "http://www.springframework.org/dtd/spring-beans-2.0.dtd">


声明

1.本站遵循行业规范,任何转载的稿件都会明确标注作者和来源;2.本站的原创文章,请转载时务必注明文章作者和来源,不尊重原创的行为我们将追究责任;3.作者投稿可能会经我们编辑修改或补充。

发表评论
搜索
排行榜
KIKK导航

KIKK导航

关注我们